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Sas Jacobs 

What’s new in Flash 8 
Welcome to the first in a series of articles about the new release, Flash 8. Like Flash MX 2004, Flash 8 comes in 
two versions - Basic and Professional.  Flash Professional 8 is aimed at advanced web designers and 
application developers. It includes the same features as Flash 8 Basic but adds some extra tools to help with 
more complicated animations and video.  
 
Some Flash designers felt that the new features in Flash MX 2004 were aimed at developers. Designers will be 
very happy with the new features in Flash 8 as they affect drawing and animations as well as scripting. There 
are also improvements to some of the existing features of Flash. Whatever your role, I’m sure you’ll enjoy the 
improvements and enhancements that Flash 8 can offer. 
 
Within these articles, I will explore both editions of Flash 8. The articles will cover the following topics: 

• Changes that affect all versions of Flash 8 
• Changes that affect Flash 8 Professional only 
• Changes in ActionScript 2.0 within Flash 8 
• Drawing in Flash 8 
• Graphic Filters 
• Blend modes 
• Animating in Flash 8 
• New scripting features in Flash 8 
• New text features in Flash 8 
• Scripting filters and blends 
• New bitmap features within Flash 
• File uploads in Flash 
• Working with the video in Flash 8 

 
I’ll start by looking at the main changes to Flash 8. These changes apply to both Flash Basic 8 and Flash 
Professional 8. They include changes in the areas of: 

• The Workspace 
• Drawing models 
• Gradients 
• Drawing rectangles and ovals 
• Text 
• Undo  
• Meta data 
• Playback security 

 
You’ll need Flash 8 to see the new features explored in this article.  It doesn’t matter whether you have the 
Basic or Professional Edition as everything discussed here applies to both. You can download a trial version 
from the Macromedia Web site.  This article doesn’t contain any exercises but you’ll probably want to have 
Flash 8 open as you read so you can explore the new features. 
 
We’ll start by looking at changes to the way the Flash workspace is organised. 

Workspace changes 
There are several changes to the workspace in Flash including changes to the: 

• Pasteboard 
• Tools panel 
• Colour picker 
• Property Inspector 
• Actions panel 
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• Panel sets 
• Library 

 
I’ll look at each of these changes in the first part of this article. 

Pasteboard changes 
The Pasteboard is the area around the Stage. You can use for storing objects that don’t appear on the 
Stage. In Flash 8, the Pasteboard has been expanded so you can store more objects there. This is a relatively 
minor change but I know I’m going to find it a useful one. 

Tools panel changes 
The Tools panel within Flash 8 has been rearranged. None of the tools have been removed and the screen 
shot below shows the Tools panels from Flash MX 2004, side by side with the Tools panel from Flash 8. 
 

  

Flash MX 2004 Tools panel Flash 8 Tools panel 
 
In Flash 8, you can see that all the selection and transformation tools have been grouped together at the 
top of the Tools panel.  
 
You can still customise the tools and their arrangement within the Tools panel by using Edit > Customize Tools 
Panel. The screenshot below shows you the Customize Tools Panel dialog box. Select a tool position on the 
left hand side and choose a new tool from the available tools. You can use the Add and Remove buttons to 
make changes. 
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Colour picker 
Flash 8 has also changed the Colour Picker slightly and I know I’ll find this change very useful. When you 
open the Color Picker, you will be able to choose a colour and set the Alpha value for both strokes and fills. 
You can see the new setting in the screen shot below. You can type in your own Alpha value here or choose 
a value using the slider. 
 

 
 
In earlier versions of Flash, you could only choose a colour in the Color Picker. If you wanted to set the Alpha 
value, you had to use the Color Mixer panel. In Flash 8, you can still use that panel as well. 
 
You might also notice that the size of the Color Picker has increased in Flash 8. I’ve shown the two side-by-
side so you can see the difference. It’s a small change but it makes Flash 8 a little more user friendly. 
 

 

 

Flash 8 Flash MX 2004 
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Property Inspector 
The Property Inspector includes tabs for both Parameters and Filters. Parameters apply to components. Filters 
allow you to apply graphic filters to your objects. Note that these are only available in Flash Professional 8. 
You can find out more about filters in the next article. 
 

 
 
You might also notice some new options in the screen shot above. For example, two or the disabled options 
include Blend and Use runtime bitmap caching. Both of these options are available in Flash Professional 8 
and I’ll cover both topics in more detail in the next article. 

The Actions panel 
The Actions panel has changed slightly in Flash 8. It now includes a drop down list at the top left that allows 
you to select your ActionScript version.  
 

 
 
You can choose between ActionScript 1.0 & 2.0, Flash Lite 1.0 ActionScript and Flash Lite 1.1 ActionScript. 
 
The right hand side of the Actions panel includes a Script Assist button. Script Assist helps people to write 
code and is likely to be useful for people starting out with ActionScript or those that don’t write code as part 
of their daily tasks. It’s a little like the Normal mode that was available before Flash MX 2004. I’ll cover Script 
Assist more in a later article. 
 

 
 

When you turn on Script Assist, you’ll be able to use the form at the top of the panel to fill in details of your 
code. Select the item to script by clicking the plus sign at the top of the panel. You may have to navigate 
through several menus to find the correct action. 
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Once you’ve chosen an action, you’ll see a form that allows you to fill in the details. When you enter these 
details, the ActionScript will be built for you in the lines below. Note that you can’t directly edit the 
ActionScript lines when you’re working with Script Assist. 
 

 
 

You might also notice that the colour coding for ActionScript has changed a little. You can specify which 
colours are used in this panel by choosing Edit > Preferences > ActionScript. 
 

 

Panel sets 
The way that panels are organised has changed in Flash 8. You can now group panels together in panel 
sets. You’d probably do this to keep similar functionality in the same place and you may be familiar with this 
concept if you’ve worked with Photoshop. Each panel appears as a tab within the set. You can switch the 
tabs between sets and give each a custom name. 
 
For example, I work with components a lot and it would be useful for me to group the Components and 
Component Inspector panels together. I can do this by clicking on the panel menu button of the 
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Component Inspector (at the top right of the title bar) and choosing the Group Component Inspector with 
option. I can then choose the Components panel, as shown below. 
 

 
 
I’ll end up with a panel set containing two tabs - one for each of the original panels. 
 

 
 

I can click the panel menu button and choose the Rename panel group option if I want to give the panel 
group a new name. 
 

 
 
If I want to remove the Component Inspector from the panel group, I can right click the Component 
Inspector tab and choose Group Component Inspector with > New panel group.  
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The Component Inspector would then appear in its own panel.  

Library 
The Flash 8 Library operates in a different way compared with previous versions of Flash. In Flash MX 2004, if 
you were working with the multiple Flash files, each library opened in a different panel. This means that you 
could end up with several library panels, as shown below. 
 

 
 

In Flash 8, all movies are available through a single Library panel as shown below. You can switch between 
libraries by choosing from the drop down list. 
 

 
 
However, you can still split the libraries into separate panels. Click the New library panel button and you’ll 
open the selected library in a new panel. You might need to do this if you want to drag symbols from one 
library to another. 
 

 
Another change is that you can now drag components directly into the Library panel. In Flash MX 2004, you 
had to drag a component to the Stage and delete it in order to add it to the Library.  
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One of the biggest changes to Flash 8 is the new Object Drawing model. 

Drawing in Flash 
Flash 8 includes a new feature called the Object Drawing model. This means that Flash 8 provides two 
models for you to use when drawing shapes. These are the: 

1. Merge Drawing model 
2. Object Drawing model 

 
Let’s look at each model. You might find it useful to open Flash and experiment with drawing shapes so you 
can see the differences for yourself. 

Merge Drawing model 
Earlier versions of Flash used the Merge Drawing model. This means that when you draw a shape on top of 
another in the same layer, they automatically merge. So if you added a circle on top of another and 
removed it again, the top circle shape would be cut out of the bottom circle shape, as shown below. 
 

 
 
The only way to stop this was to add the shapes on different layers. Objects drawn in this mode show the 
word Shape in the Properties panel. 
 

 
 
When you select Shape objects, you’ll see the entire shape shaded with small dots. 
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You can still draw shapes in this way in Flash 8. 

Object Drawing model 
Flash 8 includes an additional drawing model called the Object Drawing model. When you turn on this 
option, shapes don’t automatically merge as they do in the Merge Drawing model.   
 
Start by selecting the tool you want to draw with and turn on Object Drawing in the Options section of the 
Toolbox as shown below.  
 

 
 
This setting is available in the Pencil, Line, Pen, Brush, Oval, Rectangle and Polygon tools. It acts a toggle 
between the two drawing models. 
 
After you’ve drawn the shape with this option selected, you’ll notice straight away that it is surrounded by a 
blue selection box instead of being shaded with dots. 
 

 
 
You’ll have seen this type of selection box in earlier versions of Flash when you worked with grouped shapes 
and symbol instances. The Properties panel also shows the object to be a Drawing Object instead of a 
Shape. 
 

 
 
Don’t get confused by the blue box. The drawing is still an object and won’t appear in the library until you 
convert it to a symbol. 
 
If you overlap two Drawing Objects and drag them apart again, you won’t take a bite out of the bottom 
shape as you do with the Merge Drawing mode. They’ll remain as complete Drawing Objects. You can still 
edit the Drawing Object as you normally would edit a Shape.  
 
We’ll look more closely at the Object Drawing mode in the article on the new drawing features in Flash 8. In 
that article, you’ll see how we can merge Drawing Objects in different ways. 
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Gradients 
Flash 8 allows you to apply complicated gradient fills to your objects. In this version, you can now have up to 
15 colour points in your gradient. The way they’re created is slightly different to earlier versions of Flash.  
 
In Flash 8, when can directly edit the colour points in the gradient by double clicking them. In earlier versions, 
you had to use the swatches above. When you double click a point in the gradient, the Color Picker will pop 
out as shown below. 
 

 
 
You’ll notice a checkbox for Linear RGB in the Color Mixer. If you check this box, Flash will create a gradient 
that is compatible with the Scalable Vector Graphics (SVG) specification. If you don’t select this option, Flash 
uses its own gradient format. 
 
When you use the Gradient Transform tool, the transform handles have indicators that show their purpose. In 
Flash MX 2004, you had to hover over the handles to see the shape change for each of the handles. 
 

 
 
Flash 8 includes Overflow modes which allow you to specify how colours are applied beyond the gradient. 
This applies where the gradient fills only part of a shape.  
 
I’ll show you how these options work on the following linear gradient. 
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In the Drawing Object above, the linear gradient completely fills the shape. If I use the Gradient Transform 
Tool to reduce the size of the gradient, I can choose from several different Overflow options. 
 

 In this option, the first and 
last colours in the gradient 
are extended to fill the 
object. 

 

 

This Overflow option reflects 
the gradient and repeats 
the reflection to fill the 
object. 

 

 

In the last option, the 
gradient is repeated 
throughout the object, 
without a reflection. 
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Drawing rectangles and ovals 
Flash 8 provides another way to draw rectangles and ovals, using a dialog box. Select either the Rectangle 
or Oval tool and Alt-click on the Stage, where you want the shape to appear. You’ll see a dialog box where 
you can enter the settings for the new shape. 
 
The settings are slightly different depending on which tool you’ve chosen. You’re able to set the size of the 
object and choose whether or not to draw the shape from the centre. If you leave the Draw from center 
option selected, the centre of the new shape will appear at the point where you clicked on the Stage. You 
can also specify rounded corners in the Rectangle Settings dialog box. 
 

  

Rectangle Settings dialog box Oval Settings dialog box 

Text changes 
When you use the Text tool to add a text field to your Flash movie, you’ll notice some differences in the way 
Flash displays the text. There are also some different options for working with text in the Property Inspector. 
 
The image below shows text fields within Flash 8 compared with Flash MX 2004. 
 

 
Static text in Flash 8 

 
Dynamic and input text in Flash 8 Flash MX 2004 

 
You’ll notice that there are resize handles on the text fields within Flash 8. This allows you to resize the field by 
dragging the handles. In Flash MX 2004, you had to use the Text tool to click inside the text field and drag the 
resize handle as shown below.  

 
 
In Flash 8, you can use the Selection tool without having to activate the text field first. 
 
Flash 8 also includes FlashType - a new text rendering engine. It provides high-quality text rendering, 
especially for small font sizes. This improves the appearance of text within Flash movies. FlashType is 
automatically selected when you publish to the Flash 8 player. It’s disabled when you rotate or skew a text 
field and for font sizes over 256 points. You can’t use FlashType with Flash Player 7 or earlier. 
 
The downside is that using FlashType with different fonts may cause a slight delay when you load a SWF file 
and it may also increase the file size. The Help menu suggests the effect will be noticeable if you’re using four 
or five different character sets within the first frame. Macromedia suggest that the Flash Player’s memory 
usage may increase by approximately 4 MB in this case. 
 
Flash 8 allows you to specify the amount of anti-aliasing to apply to a text field by selecting the appropriate 
option in the Property Inspector.  
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Basically, the names tell you what purpose the settings serve. You’ll learn more about these anti-aliasing 
options in a later article that covers text features in Flash 8.  

Object level undo 
The new Object level undo feature allows you to keep track of any changes you make to an object.  In 
effect, each object has a list of actions associated with it that can be undone without affecting changes 
that you’ve made to other objects. 
 
You can turn on this feature within Edit > Preferences. In the General section, you can switch between 
Document-level Undo and Object-level Undo. 
 

 
 
You can’t undo the following changes in Object-level Undo. 
 

• Enter Edit mode  
• Exit Edit mode  
• Select Unused Library items  
• Select Library Items  
• Add Library Item  
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• Delete Library Item  
• Duplicate Library Item  
• Modify Library Item  
• Modify Library symbol behaviour  
• Rename Library items  
• Move Library items  
• Edit Library items  
• Import to Library  
• Create font symbols  
• Create library folders  
• Expand all library folders  
• Create video stream symbols  
• Convert to compiled clip  
• JSFL library edits  
• Modify bitmap symbol properties  
• Modify sound symbol properties  
• Modify library item linkage  
• Convert to symbol  
• Create new symbol  
• Run JSFL command  
• Run JSFL file  
• Modify movie properties  
• Import  
• Create scene  
• Delete scene  
• Duplicate scene  
• Rename scene  
• Move scene 

Meta data 
Flash 8 allows you to add Meta data to your SWF files as you would with HTML pages. You can do this 
through the Modify > Document menu. This opens the Document Properties dialog box. 
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You can enter a title for the document as well as a description. Then the data that you’ve added will be 
available to search engines so that your Flash movie can be listed correctly. Note that you’ll need to set 
these options for each Flash movie that you create. 

Playback security 
Flash Player 8 includes a new security model for the SWF files that you publish. When you test SWF files in a 
Web browser of standalone player, you must decide whether these files are allowed to access local or 
network files.  
 
The SWF files you create are automatically allowed to read from local files and networks. However, they’re 
not allowed to communicate with networks unless you specifically grant this permission. When you give a 
SWF file permission to access networks, it can no longer access the local system. In other words, you can 
access either the local network or a remote network but not both.  
 
The new player security model will affect any requests that you make using http:// and https://. So, if you’re 
using the loadMovie, sendAndLoad or Load actions and you refer to an http:// link, you’ll need to publish the 
file with permission to access network files. 
 
This has been implemented so that Flash can’t exchange data between local and remote networks. It stops 
people from using a remote Flash file to interrogate a local system. Hopefully, it will stop people from using 
Flash files for dishonest reasons. 
 
You can change the playback security settings in File > Publish Settings. Select the Flash tab and choose 
from the Local playback security drop down box. 
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If you don’t set this option correctly, users will see a dialog box advising them about security settings. There 
are also other options that you can use to manage the security settings for the Flash Player. For example, 
developers can change configuration settings to specify the types of security warnings that appear. 
Developers can also determine folders and application that are to be trusted by the Flash Player. 

Conclusion 
Well, this article covers the main changes that have been introduced to both Flash Basic and Flash 
Professional 8.  I hope you enjoyed this article and were able to play with some of the new features. In the 
next article, I’ll look at the changes that only affect Flash 8 Professional. 
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