App Connect Background Video Support Product Page

Solved

adding video breaks site css

Reported 10 Jun 2019 10:01:37
1
has this problem
10 Jun 2019 10:01:37 Jamie F posted:
Hi

Have just puchased the background video app and am trying to add a video to a page.

Without the video, the test page looks like this clients.motley.site/puregreen/test/template.html and the intention is to add the video to the container with class="row headerLayer"

When I do that, the page looks like this clients.motley.site/puregreen/test/template2.html

Your advice how to get the video to display within that container without it breaking the rest of the css would be appreciated.

Am running DW 2015.3 7888 on Windows 10

Thanks

Jamie

Replies

Replied 10 Jun 2019 11:58:35
10 Jun 2019 11:58:35 Teodor Kuduschiev replied:
Hello,
How exactly did you add the video there? Can you explain step by step please?
Replied 10 Jun 2019 12:28:27
10 Jun 2019 12:28:27 Jamie F replied:
sure, have done a screen capture video of it - which can be downloaded here www.motley.site/misc/ice_video_20190610-131715.zip

the page that was 'created' in the video is this one: clients.motley.site/puregreen/test/template3.html
Replied 10 Jun 2019 12:35:57
10 Jun 2019 12:35:57 Teodor Kuduschiev replied:
It's because of your page structure.
Please move the video player tags inside the row ...

<div id="bgvideo1" is="dmx-background-video" src="images/misc/26859013-preview.mp4">

Replied 10 Jun 2019 12:41:05
10 Jun 2019 12:41:05 Jamie F replied:
sorry, which tags do you mean?
Replied 10 Jun 2019 12:46:52
10 Jun 2019 12:46:52 Teodor Kuduschiev replied:
Put the video player div inside this ROW you are trying to put the video into. I pasted which tag in my last post.
Replied 10 Jun 2019 13:08:56
10 Jun 2019 13:08:56 Jamie F replied:
i had tried that already but have done it again so you can see clients.motley.site/puregreen/test/template3.html

it just breaks the css in a different way.

I noticed that if I removed 'overflow:hidden' (from
<div style="position: absolute; width: 100%; height: 100%;  overflow: hidden; ">

) in webmaster tools, then the video becomes visible but then other css becomes broken.
Replied 10 Jun 2019 13:24:01
10 Jun 2019 13:24:01 Teodor Kuduschiev replied:
There is something strange in your page layout/css which is causing this.
Please remove the video player tags from your page and add the video attributes to your row headerLayer to test if it works fine:


<div class="row headerLayer" id="bgvideo1" is="dmx-background-video" src="images/misc/26859013-preview.mp4">


Replied 10 Jun 2019 13:32:36
10 Jun 2019 13:32:36 Jamie F replied:
ok thats worked...many thanks

Reply to this topic