Online Page Editor Add-on Support Product Page

In progress

Can't log into editor using PHP on a Linux server

Reported 19 Aug 2013 19:33:05
has this problem
19 Aug 2013 19:33:05 Billie Cornell posted:
I have the Online editor working on a Windows server but can't seem to get it working on a Linux server. It gives me the log in window but when I try and log in using the user id and password I set up I get the log in screen 3 times and then an access denied window.
What am I doing wrong?



Replied 20 Aug 2013 07:44:33
20 Aug 2013 07:44:33 Teodor Kuduschiev replied:

Please provide the login details.
Replied 20 Aug 2013 12:23:25
20 Aug 2013 12:23:25 Billie Cornell replied:
Ctrl \

Replied 21 Aug 2013 08:57:51
21 Aug 2013 08:57:51 Teodor Kuduschiev replied:
Can you please tell me what Login Method are you using:
- Ajax login box
- HTTP Authentication
Replied 21 Aug 2013 12:26:12
21 Aug 2013 12:26:12 Billie Cornell replied:
HTPP Authentication. I tried Ajax login box and I don't get a login screen at all.
Replied 21 Aug 2013 12:28:07
21 Aug 2013 12:28:07 Teodor Kuduschiev replied:
Please switch to ajax login box, so i can inspect the issue with it not appearing.
Replied 21 Aug 2013 14:05:55
21 Aug 2013 14:05:55 Billie Cornell replied:
Ok. I changed it to an ajax login box and uploaded it.
Replied 21 Aug 2013 14:21:32
21 Aug 2013 14:21:32 Teodor Kuduschiev replied:
It just says - invalid login. Please send me your file to:
Replied 21 Aug 2013 14:41:07
21 Aug 2013 14:41:07 Billie Cornell replied:
Ok. I'm not even getting the ajax login box. hum....
Replied 21 Aug 2013 14:51:17
21 Aug 2013 14:51:17 Teodor Kuduschiev replied:

I think the problems on your page is you have an older version of jquery on you site. Please remove the following file: oth locally and remotely. Then open your page in dreamweaver and just reapply the editor, this will recreate the file to its latest version. Then upload the file to your server.
Replied 21 Aug 2013 16:05:55
21 Aug 2013 16:05:55 Billie Cornell replied:
Ok, I did that but I still don't get anything. Do I need something turned on in my Browser?
Replied 22 Aug 2013 08:22:42
22 Aug 2013 08:22:42 Teodor Kuduschiev replied:
Seems like there are other old file versions on your server.
Please remove the whole scriptslibrary folder, go to code view, remove the following lines:

<script type="text/javascript" src="ScriptLibrary/dmxEditor.min.js"></script><script type="text/javascript" src="ScriptLibrary/dmxPageEditor.js">

And reapply the editor, then upload the newly generated files to your server.
Replied 22 Aug 2013 12:37:20
22 Aug 2013 12:37:20 Billie Cornell replied:
Well, I deleted the ScriptLibrary folder and the Styles folder and the test.html page on both local copy and server copy. Recreated the page added the page editor back in and I'm still getting nothing.
Are you getting a log in prompt?
I'm missing something..... There has to be an aha moment here.

Replied 22 Aug 2013 13:54:04
22 Aug 2013 13:54:04 Teodor Kuduschiev replied:
I just tested the page and all seems to be okay. I can log in, edit and save.
Replied 22 Aug 2013 15:00:44
22 Aug 2013 15:00:44 Billie Cornell replied:
So what am I missing on Internet Explorer? Mine doesn't pop up anything.
Replied 22 Aug 2013 16:45:43
22 Aug 2013 16:45:43 Billie Cornell replied:
I messed around with a few things in IE and still can't get it to pop up. I've tried it on a couple PCs and also one PC remotely so that it is on a completely different network. What would be blocking this to pop up? I did turn off the pop up blocking but still didn't get anything. I'm using IE 10 but also tried it on Safari and got nothing.
Sorry to be a pain.
Replied 22 Aug 2013 16:50:26
22 Aug 2013 16:50:26 Billie Cornell replied:
Aha. It works in Firefox. So, what is IE doing to block it that Firefox isn't?
Replied 23 Aug 2013 12:03:57
23 Aug 2013 12:03:57 Billie Cornell replied:
Any idea on why this doesn't work in IE or Safari? I really don't want to have to tell the client he has to use Firefox to edit his website. That just seems silly. There has to be a setting in there someplace. I've search the internet but don't see anything related. This happens on more than one pc so it's not a pc issue.

Thanks for you help.
Replied 23 Aug 2013 12:15:40
23 Aug 2013 12:15:40 Billie Cornell replied:
I ran the debugger in IE and here is the error I'm getting.
SCRIPT5007: Unable to get property 'msie' of undefined or null reference
jquery.simplemodal.min.js, line 8 character 14

Is there something I need to upgrade or install?
Replied 26 Aug 2013 08:45:52
26 Aug 2013 08:45:52 Teodor Kuduschiev replied:
Hello Billie,

Can you please try changing the login combination to ctrl+shift+2 and check if the issue still exists?
Replied 26 Aug 2013 12:44:20
26 Aug 2013 12:44:20 Billie Cornell replied:
I did but I will try again.
Replied 26 Aug 2013 12:49:53
26 Aug 2013 12:49:53 Billie Cornell replied:
interesting. I get an error now.
Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; WOW64; Trident/6.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; BRI/2; IPH
Timestamp: Mon, 26 Aug 2013 12:47:50 UTC

Message: Unable to get property 'msie' of undefined or null reference
Line: 8
Char: 14
Code: 0

Message: Object doesn't support property or method 'modal'
Line: 9
Char: 205
Code: 0

Message: Object doesn't support property or method 'modal'
Line: 9
Char: 205
Code: 0

Reply to this topic