Pure PHP Upload 2 Support Product Page

Upload Size

Asked 25 May 2010 06:06:00
has this question
25 May 2010 06:06:00 craig sheppard posted:

I'm having some issues uploading larger files. Read through a few of similar topics, but I'm still a little in the dark. My settings are...

upload_max_filesize 10M
post_max_size 8M
max_execution_time 30
max_input_time 60
memory_limit 32M

The time settings seem to be ok, it's not timing out at least, I'm getting ...

Upload Error
An error has occured saving uploaded file!
Filename: IMG_5817.JPG
File is not uploaded correctly or is empty.
Please correct and try again

This image is only 2.3MB

All the size settings in the ini would seem to be more than enough for an image that size. The folder permissions are fine (777). I can't think of anything else, any advice please?!

Thanks in advance.



Replied 25 May 2010 09:43:00
25 May 2010 09:43:00 Miroslav Zografski replied:
Hello Craig,

Is it only one image that you have problems with? If so open it in Photo Shop or similar program and save it for web.

Replied 25 May 2010 09:55:10
25 May 2010 09:55:10 craig sheppard replied:
Hi Miroslav,

Thought of that, but I've tried many images and none are showing anything weird in Photoshop, all valid image files, not truncated or anything strange.

I've also reinstalled the extension, redone the file from scratch (just a simple form with the file field and a text field that inserts into the database), had sipp on it also but took that off to diagnose, it has me stumped.

Any help you can provide is much appreciated.
Replied 25 May 2010 09:57:41
25 May 2010 09:57:41 craig sheppard replied:
Is dpi an issue? These will generally be pics straight out of a digital camera which these days often start at 240dpi, but I can't imagine why that would be an issue with the upload. If it was affecting sipp (I'll get to that once I solve this) I could understand, but it's just uploading a file.

My users aren't very tech savvy so to ask them to alter the file in any way is out of the question.
Replied 25 May 2010 10:29:09
25 May 2010 10:29:09 Miroslav Zografski replied:
Hello Craig,

The problem with sipp may be the low memory limit.

For the PPU:
set in the beginning of the page (right after the php includes) following:
<?php $DMX_debug = true;?>
and remove any redirections. Than try uploading a file and pass here any debug info.

Replied 26 May 2010 01:16:40
26 May 2010 01:16:40 craig sheppard replied:
Hi Miroslav,

Just to be clear, there's no sipp on the page yet, get one thing working at a time.

This image is 2.2MB, here's the debug output...

Pure PHP Upload version 2.1.10

PHP version(5.2.9)
Setting timeout
fullPath = /images/clpics/
Check path
Starting to progress files
field = addcp
filename = DSCN2545.jpg
CleanUp FileName
new filename = DSCN2545.jpg
Checking fileSize
Checking extension
comparing JPG with GIF
comparing JPG with JPG
comparing JPG with JPEG
comparing JPG with BMP
comparing JPG with PNG
Upload Error

An error has occured saving uploaded file!

Filename: DSCN2545.jpg
File is not uploaded correctly or is empty.
Please correct and try again
Replied 27 May 2010 09:46:02
27 May 2010 09:46:02 craig sheppard replied:
Getting a bit desperate here guys....

Replied 28 May 2010 10:54:28
28 May 2010 10:54:28 Miroslav Zografski replied:
Hello Craig,

In the ppu UI there is a setting for the time out of the script. You could set that to 600. Also increase the memory limit to 64M.

Check to see if that makes any difference.

Replied 28 May 2010 22:44:14
28 May 2010 22:44:14 craig sheppard replied:
Thanks for your help Miroslav,

I had a chat with my host, the costume php.ini on my service (they still don't know why) hasn't taken effect. They've made the changes to the default setup server wide for now and everything now works as it should - uploading 10MB with ease.

If anyone in Australia is looking, aussiehost.com - great support, great host.

Thanks again.
Replied 31 May 2010 09:51:01
31 May 2010 09:51:01 Miroslav Zografski replied:
Hello Craig,

Thanks for the feed back.
Nice to hear you have your problem solved.


Reply to this topic