Smart Image Processor ASP 2 Support Product Page


SIP Cannot work on all .net versions?

Asked 04 Apr 2012 11:00:30
have this question
04 Apr 2012 11:00:30 Dan Salter posted:
I have the SIP extension working perfectly on two computers, but not on my remote hosted server. The error I am getting is "There is no supported component detected." I have the component in the Bin directory on the root folder, and all the scripts are uploaded exactly the same as the two local machines - quadruple checked. The only difference I can see is that my server is using a much older version of .Net - v1.1.4432 - is this the problem? DO I need to upgrade the .net version on my server?


Replied 04 Apr 2012 12:12:42
04 Apr 2012 12:12:42 Teodor Kuduschiev replied:
Hello Dan,

Please check this article:
Replied 04 Apr 2012 18:45:55
04 Apr 2012 18:45:55 Dan Salter replied:
Thanks Teodor,

very helpful indeed for debug, but not yet solved.

Please take a look at the following outputs from the detect.asp, and its debug response. It seems to be a problem with object creation by sip_service.asmx.

Detect.asp Output:
Smart Image Processor Components

Detecting Components:

NOT FOUND: Smart Image Processor Own component
NOT FOUND: ASPJpeg Server Component
NOT FOUND: ASPImage Server Component
NOT FOUND: ASPSmartImage Server Component
NOT FOUND: ImgWriter Server Component
NOT FOUND: AspThumb Server Component
Object Msxml2.ServerXMLHTTP.4.0 created
Smart Image Processor can be fully used on this server!
When I run the debug:
Image Processor 2.5.6 debug
Url to ASP.NET service www.<MYSERVER>.com:80/Upload_Fun/../ScriptLibrary/sip_service.asmx
Error creating object Msxml2.ServerXMLHTTP.6.0 006~ASP 0177~Server.CreateObject Failed~800401f3
Error creating object Msxml2.ServerXMLHTTP.5.0 006~ASP 0177~Server.CreateObject Failed~800401f3


It seems that sip_service is having problems creating objects. Not sure why it is needing or attempting to create Msxml2.ServerXMLHTTP.6.0, or Msxml2.ServerXMLHTTP.5.0, since (from the detect.asp output) it is Msxml2.ServerXMLHTTP.4.0 that is required.

Also note from the detect.asp output that Msxml2.ServerXMLHTTP.4.0 does exist on my server, and also that it can be successfully created by a user with the same priveledges as the user that would be uploading and resizing images...

To eliminate possibilities of permissions issues, I have granted full permissions on the scriptlibrary, the folder in which watermark images are held, the uploads folder, and also the bin... I will undo these one by one when I solve the problem

Any help much appreciated...

Replied 04 Apr 2012 19:49:19
04 Apr 2012 19:49:19 Dan Salter replied:
Solved the above - with the first reboot of my server in 17 weeks... Simple, but I hate cutting off active internet users and rebooting...

So, I can now get to my upload page with no errors. But new problem: after I have submitted file for upload I get this:

Upload Error
(21) Translation for PU3_ERR_SAVE not found.

Please note - the uploads are working fine on two local machines but not on my main server, and I am certain the same file structure exists on all three machines...


Replied 05 Apr 2012 03:26:18
05 Apr 2012 03:26:18 Dan Salter replied:
Just realized that the Upload error reported above is not a SIP problem, but an Upload3 problem. When searching the forums for this problem in the Upload3 forum, there is good clear responses - basically checking permissions, and following all advice there it is now working. So no need for more replies on this topic, I am now sorted...

The most important 'learning' I can share from this whole experience is: If your computer has downloaded automatic windows updates but you have not yet rebooted the system - i.e. taken your web site off line and rebooted the server, you could run into issues like I experienced above with SIP above... So try that first / at least exclude that...
Replied 05 Apr 2012 06:22:07
05 Apr 2012 06:22:07 Teodor Kuduschiev replied:
Hello Dan,

I'm glad you managed to resolve the issue using our FAQ section and Forum.

Reply to this topic