DMXzone Database Updater ASP Support Product Page


internal server error

Reported 03 Dec 2013 18:32:16
have this problem
03 Dec 2013 18:32:16 Simone De Marchi posted:
I've a problem when use Updateter ASP extension. When I post my insert form the browser tell me "INTERNAL SERVER ERROR" but I don't see any debug information...
here the link:

Help me please

Best regard


Replied 08 Jan 2014 08:48:20
08 Jan 2014 08:48:20 Dik Hendriks replied:
I also get an error on insert: 500 (Internal Server Error)

Uncaught SyntaxError: Unexpected token E

Regards, Dik Hendriks
Replied 08 Jan 2014 10:27:31
08 Jan 2014 10:27:31 Teodor Kuduschiev replied:
Hello Dik,

Can you please provide a link to the page you are using to insert data?
Replied 08 Jan 2014 10:38:46
08 Jan 2014 10:38:46 Dik Hendriks replied:

It is a test-page, only the insert action is enabled so far.
Replied 08 Jan 2014 10:51:10
08 Jan 2014 10:51:10 Teodor Kuduschiev replied:
Can you please tell me what is the database field you are trying to insert into the Info textarea content?
Replied 08 Jan 2014 10:59:59
08 Jan 2014 10:59:59 Dik Hendriks replied:
the 'body' field ( nvarchar(MAX) ).

The text area field will in the final version be replaced by a Advanced html editor input.
Replied 08 Jan 2014 11:26:16
08 Jan 2014 11:26:16 Teodor Kuduschiev replied:
Can you please check if you have the latest version of database update installed?
Replied 08 Jan 2014 11:48:20
08 Jan 2014 11:48:20 Dik Hendriks replied:
I use version 1.1.0
Replied 08 Jan 2014 14:20:42
08 Jan 2014 14:20:42 Teodor Kuduschiev replied:
Please zip and email me the asp files located in the dmxConnections and dmxDatabaseActions folders. My email:
Replied 07 Mar 2014 18:37:05
07 Mar 2014 18:37:05 Steve Skinner replied:
Same problem for me too. Access db, simple two field form. Followed the video tutorial for insert. Doesn't work - "internal server error"
Replied 07 Mar 2014 19:12:57
07 Mar 2014 19:12:57 Steve Skinner replied:
Maybe you can help me troubleshoot this further. Here's my sample page.

The add link tool at the top was built by following the tutorial video for inserting with the Database Updater. It doesn't work - just gives "internal server error". However, I have also set up a delete icon and attached that to a delete function using the Database Updater as well - and it works.

For test purposes, I build a simple page for adding links using the regular (old) DW insert record behavior, just so I have a way of getting this information into a database. You can use this page to enter links if you need:

So, this test proves that there's no issue with permissions and writing to the database. It's just that the database updater is not getting it done. Let me know if I can provide any further information to help figure this out.
Replied 07 Mar 2014 19:31:37
07 Mar 2014 19:31:37 Teodor Kuduschiev replied:
Hi Steve,
The error on your page is:

Quote[Microsoft][ODBC Microsoft Access Driver] The INSERT INTO statement contains the following unknown field name: 'hplinks.linkTitle'. Make sure you have typed the name correctly, and try the operation again.

Please check if you are trying to insert into the proper field(s)
Replied 07 Mar 2014 21:55:47
07 Mar 2014 21:55:47 Steve Skinner replied:
Yes, the table is hplinks and one of the fields being written to is linkTitle. That is all correct.

I'm curious Teodor, how did you see that descriptive error message? I just see the one "internal server error" message, which is useless in troubleshooting.
Replied 07 Mar 2014 23:01:47
07 Mar 2014 23:01:47 Steve Skinner replied:
I even tried recreating a new database updater action for adding a link, thinking that maybe something was screwey with the original one I created, but I ended up with the same results - same error.

It will be nice when these new extensions get to the point where they "just work". I feel like I'm part of a beta test.
Replied 10 Mar 2014 10:10:32
10 Mar 2014 10:10:32 Teodor Kuduschiev replied:
I see the detailed error in the browser developer tools console, in the Response section.
Please provide a little more detailed information - what is the Access database you are using, what is your server version, what is the access driver you are using?
Also - what is the linkTitle field type?
Please send the /dmxDatabaseActions/Insert.asp zipped to in order for us to check it.
Replied 10 Mar 2014 18:05:50
10 Mar 2014 18:05:50 Steve Skinner replied:
The access db is in 2002-2003 compatible format. (mdb)

Database type:
When first setting up my database connection with the database connector extension, I tried using the first "Access" database type, but it wouldn't connect, so I switched it to "Access ODBC", which connected right away.

Currently using Access ODBC Mdb

Field types:
Both fields (title and URL) are "short text" field type (255 field size)

The insert.asp file has been emailed to you...
Replied 11 Mar 2014 20:46:42
11 Mar 2014 20:46:42 Teodor Kuduschiev replied:
This will be improved in the update that is coming tomorrow (March 12)
Replied 20 Mar 2014 14:21:41
20 Mar 2014 14:21:41 Dik Hendriks replied:
Problem with the nvarchar(MAX) colomn type in SQL Server 2012+ still not solved?
Replied 27 Jun 2014 12:56:12
27 Jun 2014 12:56:12 Simone De Marchi replied:
Hi I need a fast help. If I use updater to insert new record with date and short text fields in access database it work fine. But if I use Long text database field Page tell INTERNAL SERVER ERROR.

I need help
Thank you
Replied 04 Mar 2015 13:03:37
04 Mar 2015 13:03:37 Dik Hendriks replied:
I am trying to update data in a access database. I am getting an 'Internal Server Error'.

It seems something is goes wrong when using 'Memo' fields, in the connection file Memo fields get a size 0.

"long": {"type": 130, "size": 0 "nullable": 1}

Same problem as with the nvarchar(MAX) field?

Please reply?

Reply to this topic