HTML5 File Upload Support Product Page


Click submit, nothing happens.

Asked 10 Dec 2015 20:48:28
have this question
10 Dec 2015 20:48:28 David Stoltz posted:
I followed the tutorial word for word - but when I click the submit button, nothing happens. I noticed there is no "action" attribute for the form, which I guess is OK since it's using jQuery...?

Do any special permissions need to be set on the upload folder? If so, this isn't even mentioned in the manual.

What else can I check?


Replied 11 Dec 2015 08:01:15
11 Dec 2015 08:01:15 Teodor Kuduschiev replied:
Hello David,
No special permissions are required.
Please provide a link to your page, where we can inspect what is wrong.
Replied 11 Dec 2015 13:45:40
11 Dec 2015 13:45:40 David Stoltz replied:
This problem is caused by IIS - IIS is blocking a "verb" that the HTML5 script is trying to use. If you go into "handler mappings" you can add verbs to fix this...

Problem is, I don't know which handler mapping to edit, nor do I know which verb to add....

It's IIS8 if anyone has any suggestions....

Since it's classic ASP, I think it would be the "ASPClassic" handler - just trying to figure out what verb the script is trying to use....
Replied 23 Dec 2015 20:08:26
23 Dec 2015 20:08:26 MX Addict replied:
I have the same problem with HTML5 File Upload with ASP. I follow the The Basics: Upload Files to Your Server tutorial. I test the page but nothing happens.

<!doctype html>
<meta charset="utf-8">
<title>Untitled Document</title>
<script type="text/javascript" src="ScriptLibrary/jquery-latest.pack.js"></script>
<script type="text/javascript" src="ScriptLibrary/dmxDataBindings.js"></script>
<script type="text/javascript" src="ScriptLibrary/dmxDataSet.js"></script>
<script type="text/javascript" src="ScriptLibrary/dmxServerAction.js"></script>
<script type="text/javascript">
  /* dmxServerAction name "ExeFiles" */
         {"id": "ExeFiles", "url": "dmxConnect/api/UploadFiles.asp", "form": "#UploadForm", "data": {}}
  /* END dmxServerAction name "ExeFiles" */

<form action="" method="post" enctype="multipart/form-data" name="UploadForm" id="UploadForm">
  <label for="fileField"></label>
  <input type="file" name="fileField" id="fileField">
  <input type="submit" name="button" id="button" value="Submit">

Replied 23 Dec 2015 20:21:44
23 Dec 2015 20:21:44 MX Addict replied:
And also I get this error in Explorer developertool: dmxServerAction.js (7, 988)
Replied 01 Feb 2016 12:48:51
01 Feb 2016 12:48:51 Rungnapa Sasitorn replied:
I have this exact problem, have you guys managed to sort it out?
Replied 01 Feb 2016 13:15:32
01 Feb 2016 13:15:32 MX Addict replied:
You can also view this topic. My problem is uploading to my localhost server and has to do with WIN10/IIS10
Replied 01 Feb 2016 14:20:00
01 Feb 2016 14:20:00 David Stoltz replied:
All I can tell you is this is most likely a IIS issue (verbs & handlers). I was not able to resolve this, so I emailed DMXzone for a refund - which they would not give me. Instead they sent me a link with convoluted information on how to troubleshoot the problem. Since my IIS is "vanilla" - I expected this extension to work out of the box, but it seems there are other users who are having this problem too.

This was my first request for a refund from DMXZone after buying 20+ products from them. Needless to say, I am very disappointed in their response - this extension was a waste of money since I can't use it, and they can't help resolve the problem. Not so sure I will be buying anything from them again.
Replied 01 Feb 2016 15:04:30
01 Feb 2016 15:04:30 Teodor Kuduschiev replied:
Hello David,

According to our we cannot process your refund request.
The extension has been tested and working on IIS with default settings. We have already explained you what causes your issue, and sent you an article on the IIS website, which explains how to fix it - so please just follow it. I understand that you think this is a problem with the extension, but unfortunately this is caused by your server configuration. If it was bug in the extension, this would have happened to the rest of hundred users, who bought the extension.
Replied 01 Feb 2016 15:52:27
01 Feb 2016 15:52:27 David Stoltz replied:
Hi Teodor - thanks for your reply - no sense going back and forth with this, as I've stated many times my IIS is "default" and I certainly have not changed any settings in it, but yet, the extension still does not work. I can't speak for the other users having the same problem, I can only speak for myself.

But thank you for pointing out the refund conditions, as I will consider this before purchasing anything else from DMXzone.
Replied 01 Feb 2016 16:20:12
01 Feb 2016 16:20:12 Rungnapa Sasitorn replied:
Where is this article on the IIS website? If it does not make sense to David, I am sure it will mean nothing for me, but still I would like to see it, thanks.
Replied 01 Feb 2016 16:35:05
01 Feb 2016 16:35:05 Teodor Kuduschiev replied:
Hello Rungnapa,
The error David is having is too specific.
Please contact me with a link to your page at
Replied 01 Feb 2016 18:12:12
01 Feb 2016 18:12:12 MX Addict replied:
I agree with David. It takes too long. It now four weeks ago and still can't use this extension. I need this working for a new website which is based on DMXzone Database Connectivity Collection ASP.

Uploading files is very important. So I am forged to use PAU which also still has a bug that was reported 4 month ago and isn't solved by an update.
Replied 02 Feb 2016 10:28:38
02 Feb 2016 10:28:38 Teodor Kuduschiev replied:
Hello MX Addict,
As long as i remember the issue you were having was only on your local IIS server, and everything was working fine on the remote server?
As i explained, our developers are fixing this, and this will be improved in the upcoming update. Your issue is totally different from David's issue. His issue is caused by his server config while yours is indeed an incompatibility with IIS on Win10.

As for the PAU3 issue - this has already been fixed, and i have sent the fix by email to everyone who requested it...
Replied 02 Feb 2016 20:03:55
02 Feb 2016 20:03:55 Rungnapa Sasitorn replied:
My problem was sorted. my PHP server was out of date. I changed from 5.2 to 5.4 and and that fixed it. Thanks Teodor for helping out with the issue.

Reply to this topic