App Connect Medium Editor Support Product Page

Under investigation

Medium Editor Failure

Reported 08 Aug 2017 22:24:36
has this problem
08 Aug 2017 22:24:36 Harry Bardal posted:
A new purchase/instal of Medium Editor is failing to “Enable Medium Editor” on blank unstyled php or html file with 1 basic text area. No options appear within the properties pane. App Connect is enabled and .js and .css files are linked but selecting text area and “Enable Medium Editor” does nothing — and there is no subsequent edit-ability to the text area in the browser. Tried re-instal, quit/restart, and reboot. Using DW CC17. Testing locally using MAMP. I have a number of other DMX extensions installed—all working fine. Any ideas? Thanks.


Replied 09 Aug 2017 05:50:04
09 Aug 2017 05:50:04 Teodor Kuduschiev replied:
Hello Harry,
Are you selecting the text area in the app connect tree?
Did you try iserting a medium editor text area?
Replied 09 Aug 2017 06:31:34
09 Aug 2017 06:31:34 Harry Bardal replied:
Thanks for getting back Teodor.

I have solved my problem, but the arc of it may be of interest. Every attempt I had made assumed that with the extension installed, and files properly linked, that selecting a Text Area Input would automatically generate the “Medium Text Area Properties” pane, and I’d be off and running. This didn’t work for me after going through combinations of the following conditions:
• Selection from the app connect tree
• Selection of code
• Selection of live blocks
• Text area in context of a form and outside a form
• Re-instal of extension
• Re-launch of DW
• Reboot
• Attempt in clean page
• Attempt in clean site

Inserting a Medium Editor text area via Text Data Binding > Forms > Medium Editor Textarea, did indeed work, and since this provides all the access I needed to move forward, I’m happy.

That said, the DMX video “Using App Connect Medium Editor Textarea”, does show the “Medium Text Area Properties” pane being populated spontaneously after simply selecting the text area and clicking “Enable Medium Editor”. I’d not been able to make this work, but I will certainly be trying again in future. My fault for going down a rabbit hole and not trying the other method of insertion earlier, but I had every reason to believe the first method of insertion would work based on the video. This may be a repeatable issue. Perhaps some initialization is required first time, then it works subsequently? Keep me informed if you find something. Thanks.
Replied 09 Aug 2017 07:24:10
09 Aug 2017 07:24:10 Teodor Kuduschiev replied:
Hello Harry,
Thank you for detailed explanation.
I will try to recreate your issue, and if there is a bug in the extension we will improve this in the upcoming update.

Reply to this topic