HTML5 MP3 Player Support Product Page

Solved

Its simply not working!!!

Reported 18 Feb 2012 23:58:50
3
have this problem
18 Feb 2012 23:58:50 Mark Greenwood posted:
I am seriously struggling in getting this extension to work on my site. Have been using a number of other DMX Zone extensions with no significant problems, so can't understand why this would be so different.

I have tried a number of different skins, but none of them work properly at all, and to be honest I find the instructions that go with the extension very very basic.

The website is for a festival, and for each of the bands playing I am building a profile page. This uses you 'CSS Transform - Flip' extension to open the page of each band from the main menu, and when clicking the image in the main menu I want to activate the flip, and start an mp3 demo of the band running.

I have tried a number of methods of using the HTML5 MP3 player for this purpose, but cannot even get it running correctly in stand-alone mode, let alone with a 'behaviour' start command.

If for example I use the apple skin in the bands profile page, with the one track in the list, set to autostart etc. the player graphics will show correctly on the previewed or indeed the live pages, but the player display only shows ##time## ##title## and nothing else, and the player contols will display as red when you click them but have no function to them at all. If i click on the track in the track listing, this will open a seperate tab in my browser and play back the track showing an alternative player graphic in the middle of the otherwise white screen.

Where is this all going so wrong??

Surely from what i have read pre-purchase I should be able to create a simple player with no skin in a hidden div, set to start on-click onthe same graphic that launces the flip comand. The track should then effectively playback as a background music file to the page being viewed, and then when that page is left, the same use of behaviours should enable me to stop the playback. Is that not correct??

Your earliest assistance would be very much appreciated

Thank-you

Replies

Replied 19 Feb 2012 08:21:33
19 Feb 2012 08:21:33 Teodor Kuduschiev replied:
Hello,

Pleae provide a link to your page.
Replied 19 Feb 2012 09:26:44
19 Feb 2012 09:26:44 Mark Greenwood replied:
I have sent you an email, but get an error message when I click send...here is the text again.

Other readers, please respect that this is a testing site only and that it should not be used, or the content acted on in any way...thanks

Reference my problems with the HTML5 MP3 player, please visit the temporary site location at www.rockinthebog.com/2012-test/index.html

If you click on bands, and then on the Felix Fables logo, this will activate the 'flip' but also has a start command for the player felixfables

You will see that the player is sitting at the bottom of the flipped page....the idea is that this will be in a hidden div with the scroll deactivated so that it is never actually touched.

Clicking on the photograph will flip the page back again, and ultimately will have a stop player behaviour linked to it aswell....that behaviour is not ther yet.

Right now the behaviour will not activate the player, and if you click play it opens a new window

Your help would be much appreciated.
Replied 19 Feb 2012 13:25:30
19 Feb 2012 13:25:30 Burt A replied:
I, too, am having great difficulties with the HTML5 MP3 Player and I'd have to agree that the instruction manual really did not help at all. I watched the video, too. It begins by telling you to open a Dreamweaver page and shows an AP Div,as I recall. Okay, I did that. Disaster. It shows up in 4-different ways in the 4-major browsers, so, how can I adjust the location to center it when it is showing up in 4-different locations? Then, I tried a regular DIV and had the same problem where it shows up in 4-different locations in the 4-browsers. So, I can't adjust with padding, etc. to make a good fit. Finally, my workaround was to put the player in a TABLE and that worked better than anything else. I was using the fancy red player. But, as stated above in the other e-mails, I'm still having issues getting it to work universal. It works on web/computer, but, still does not work properly on APPLE IPAD/Touch/Phone unless you disable AUTOPLAY. AUTOPLAY works fine on web/computer, but, the PLAY BUTTON does not show up on the APPLE stuff and it does not AUTOPLAY on the APPLE,either, so you can't start the player. When you disable AUTOPLAY, you see the PLAY button on the APPLE stuff and it plays fine, but, you have no AUTOPLAY feature for the web/computer.
Replied 19 Feb 2012 13:31:55
19 Feb 2012 13:31:55 Burt A replied:
By the way, I love the HTML 5 Slideshow. I bought the MP3 Player and was expecting it to work the same way. Basically, with the slideshow, I just put a cursor on the spot where I want the slideshow and insert it and it stays there and works in all the browsers and it has a size feature, as you know. With the mp3 player, as described above in my other e-mail, it does not show up in the same location in the 4-browsers and it is very hard to adjust it to fit. I tried adjusting the WIDTH in CSS and that still doesn't give a very good result because the player itself is in diffferent locations on all the browsers making adjusting it to fit neat and work really difficult.
Replied 19 Feb 2012 20:34:50
19 Feb 2012 20:34:50 Teodor Kuduschiev replied:
Hello Mark,

For some reason the scripts in your template page head tag are messed. The :

<script type="text/javascript" src="ScriptLibrary/jquery-latest.pack.js"></script>
code should be placed before all the other includes. In your case it should be immediately after the:

<!-- InstanceBeginEditable name="head" -->



Burt,

I've already sent you an email about both of your "problems":
-Problem 1 - i don't believe this is really a problem - it looks to me your design is "broken". But i will be able to tell you where the problem is when you send me a link to a page having such a problem.
-Problem 2 - - this is actually a security restriction. The Safari browser has this build in to prevent malicious websites playing all kind of stuff without user interaction. So there is nothing to do about it.
Replied 19 Feb 2012 22:17:20
19 Feb 2012 22:17:20 Mark Greenwood replied:
Ok great...certainly that has cured the issue of playback. Unfortunately, having now added a behaviour that should stop the player this now does not work.

I have added the behaviour to the image Tag in the same place as the flip back to the main screen. Flip works, but the player carries on.
Any further suggestions???

Thanks...Mark
Replied 19 Feb 2012 22:39:33
19 Feb 2012 22:39:33 Mark Greenwood replied:
Actually, it now seems to work! All I have done is to add another track to the player, so seems there may be an issue with the control if there is only a single track.

Maybe something to look in to?

My problem now appears to be that if I have multiple tracks on the player, and I want different Tag behaviours to trigger different tracks, it doesn't want to let me do that.

The option comes up to Start the player, and there is a box that says number, but no way of actually putting a track number in either that box or the player. Is this something silly that I am missing??

Regards...Mark
Replied 20 Feb 2012 07:27:53
20 Feb 2012 07:27:53 Teodor Kuduschiev replied:
QuoteMy problem now appears to be that if I have multiple tracks on the player, and I want different Tag behaviours to trigger different tracks, it doesn't want to let me do that.


You need to use 2 behaviors onClick - first - Go To Song, there you enter the song number starting with 0 for the first one, 1 for the second etc.
Second behavior is the Play.
Replied 20 Feb 2012 08:31:38
20 Feb 2012 08:31:38 Mark Greenwood replied:
Thank-you...interestingly being the impatient person I am (lol) I carried on tinkering last night and found the Go To Song option that I had not spotted before.

Did not realise that tracks started with zero though...so you have solved my problem!

For note, you do not need the play behaviour it seems. The player does not have auto-play engaged, but starts anyway on the correct track using only the Go To Song function.

Thank-you for your help
This reply was removed on 3/26/2012 10:52:12 AM.
See the changelog
Replied 25 Mar 2020 20:37:21
25 Mar 2020 20:37:21 Andrea Alessi replied:
Ho acquistato l'mp3player e l'ho inserito su un sito internet collegandolo ad un database, ma la barra di scorrimento non va avanti e non funziona.

Reply to this topic