Online Page Editor Add-on Support Product Page

Cannot get the editor to work

Reported 05 Jul 2018 11:08:44
has this problem
05 Jul 2018 11:08:44 Doug Pealing posted: Activation keys: CTRL+F2

The login prompt appears but when the user / password are filled it I get a not found response in red and the editor will not load.

This also happens on the Gadgets store showcase page.
I have tried to include a screenshot of this but this editor just gives me a and no way to upload an image.

I know this extension is pretty old but I have used it successfully in the past and have a requirement for it again.

Any help would be appreciated.


Replied 22 Aug 2018 15:47:26
22 Aug 2018 15:47:26 Doug Pealing replied:
Does anyone even look at these?
Please can I have a response even just to say that you've seen it.
Replied 23 Aug 2018 06:43:41
23 Aug 2018 06:43:41 Teodor Kuduschiev replied:
Hello Doug,
On the link your provided, there are two issues. First you have two jquery includes - one before the head tag and another one inside the head tags:

This is not fine, the jquery library must be included only once per page.

Another issue - the page eidtor js must also be inside head tags, after the jquiery include ...
Please fix these and you page will be working fine.
Replied 23 Aug 2018 09:05:27
23 Aug 2018 09:05:27 Doug Pealing replied:
Hi Teodor,

Thanks for the reply. Since this site is now live, but without the Online Page Editor, I have renamed the version which included the editor to

Thanks for the corrections to the code - I think they must have crept in whilst I was trying to get this to work. I have made the corrections as you described but still come up with the same result.

Could you have another look at it for me.
Replied 23 Aug 2018 12:20:24
23 Aug 2018 12:20:24 Teodor Kuduschiev replied:
Now the require.js file is missing from your page. It should be located before the jquery include.
Replied 24 Aug 2018 15:29:22
24 Aug 2018 15:29:22 Doug Pealing replied:
Hi Teodor
Again thanks for the reply.
Every time I open this page (which is based on a dreamweaver template) the code gets scrambled. The jquery include is added again and various other changes occur. That is why these coding errors are happening.

I have detached it from the template and just edited the code in a text editor.
I have re-applied the require.js but still cant get it working.

Activation keys: CTRL+F2
User: demo
Password: demo

Any help would be appreciated.
Replied 27 Aug 2018 06:24:41
27 Aug 2018 06:24:41 Teodor Kuduschiev replied:
Hi Doug,
I think this could be caused by the jquery version included on the page. As you mentioned, these extensions are pretty old, and i am not sure how well they work with v 3+ of jquery. Maybe you can try including the version located in the scriptlibrary folder to see if this fixes your issue.
Replied 29 Aug 2018 09:56:20
29 Aug 2018 09:56:20 Doug Pealing replied:
Hi Teodor,
I have tried that too ans still get the same result. Thank you for your help and advice with this issue but it is clearly not working. As I mentioned in my first posting on this thread it is not working on your Gadget Store demo page either.

I have now given up on this extension and am going to do what I need to do in another way.
Again thanks very much for the time you have taken looking at this for me and for your suggestions for a fix.
Best regards
Replied 29 Aug 2018 15:01:00
29 Aug 2018 15:01:00 Teodor Kuduschiev replied:
Now it is working fine, but a file on your server is missing:

Reply to this topic