DMXzone Database Connector PHP Support Product Page


Error Using This Database Connection Server Response:

Reported 22 Jun 2015 21:04:06
have this problem
22 Jun 2015 21:04:06 Dave Smith posted:
Am experiencing an error trying to update a database source to reflect new fields added to the database. My testing server is configured exactly the same as my live server including username, password, and database name. When I test the database connection it connects fine but as soon as I try to apply or via the source itself, refresh, I get the error 'Error Using This Database Connection Server Response:'

I have been through all my settings and checked my test server and live server. My database locally is exactly the same as my remote database. I use DB Forge and SQL Workbench and these connect just fine and show the new fields as they should do..

For now I have added the fields manually to the connections file used for the site but this is a workaround and not a solution.

Please can you help?

Thanks in advance!



Replied 23 Jun 2015 10:21:54
23 Jun 2015 10:21:54 Dave Smith replied:
Update! Resolved!

It appears my connection file had some how become corrupted and I do not understand why this happened as I have not edited the file for over a month...

What I did to resolve/fix the problem:

Restarted both my SQL and Apache services.
Created a new connection file.
Copy and pasted the new connection file source to my old corrupted connection file replacing the previous source.

I could then connect successfully and refresh my sources.

All very strange but none the less no longer a problem.

As ever am grateful to DMX for all the extensions they provide!

Replied 09 Nov 2015 11:32:32
09 Nov 2015 11:32:32 Ömer Faruk URSAVAŞ replied:
Hi Dave,

I am having the same problem as you did and I am confused with what you meant about the connection file. DW creates a folder named as dmxconnections and puts php files in it. Did you mean that folder and file? I deleted it and tried to create a new connection after restarting servers but the problem still exists? I could not have created a connection from scratch. Do you have any suggestions?
Replied 09 Nov 2015 11:49:00
09 Nov 2015 11:49:00 Dave Smith replied:
Hi Ömer,
If you are running a local test server and a hosted deployment server make sure they are configured exactly the same with regards to username, password and host details for the database. FTP in to your deployment server and open the dmxconnections folder and check the .php connections files match your database server credentials. If not edit as required.

You may also wish to check that your hosting allows for additional hosts to connect to the database if its away from your deployment environment (we run our database services on a separate server) and had to allow our deployment server IP to connect (rather than localhost we specify an IP).

I hope that helps? Please feel free to check and reply and I shall answer as best I can.

Best regards,
Replied 09 Nov 2015 13:30:57
09 Nov 2015 13:30:57 Ömer Faruk URSAVAŞ replied:
Hi Dave,

I really appreciate your kind help. I will pay close attention to your advice. However, the problem I am having now is that I could not have created a connection for my first demo app. MySQL is up and running and accepts connections with the same credentials that I use for DMX. I am using XAMPP as a local deployment server. Hence I don't need FTP for now. When I try to create the connection the very first time, I am getting the same error as you got in the screenshots. Therefore, I am not getting any connection php files filled with my credentials other than the generic dmxDatabase.php file which is a core file for managing operations I guess. Hence, I am kind of stuck and trying to find what might have been causing this problem. I have restarted servers and created a new site application from scratch but that's no help, either. Anyway, thanks a lot again for your quick response and help! Have a nice day!

Best regards,
Replied 09 Nov 2015 16:16:04
09 Nov 2015 16:16:04 Dave Smith replied:
OK try this Ömer,
XAMPPs default SQL installation does not allow for over complex passwords. Try re-setting your database password to something simple like 'test' (without the quotes of course).

Then see if you can connect.

If you can connect with no problems its the password that is causing the issue. No problem! When you upload the production DMX connection files simply edit them and change the password to reflect the more complex live database environment password.

Sorry for the delay in my reply I have been working on E-mail parsing and it is driving me nuts hahahaha
Replied 09 Nov 2015 16:22:55
09 Nov 2015 16:22:55 Dave Smith replied:
No worries my friend am happy to help if I can. The support team at DMX are great. Sometimes I think their delay in replying is to allow us users to figure it out for ourselves (this is usually the case with myself lol).

Replied 16 Nov 2015 19:16:05
16 Nov 2015 19:16:05 Carlin Chesnet replied:
I am getting this same error, I created the settings before the latest releases, now I cant edit or make new connections.

the files on the server work as I am able to test view from browser, but I cant create a new connection. I can reach the database via non-dw tools.
Replied 18 Nov 2015 10:24:13
18 Nov 2015 10:24:13 Dave Smith replied:
Hi Carlin,
Have you tried removing the extension all together and re-installing it? Also if you are running a local server is it being restricted by a firewall of some kind?
Replied 30 Nov 2015 10:12:46
30 Nov 2015 10:12:46 simon m replied:
Hi all,

I have just setup a new site and database, and I am getting this same error. I have been using the extension without problems on another site.

The local and testing servers are the same, I have removed and re-installed the extension, I have re-created the site in Dreamweaver, but still the 404 error when requesting dmxdatabase.asp exists, even though the file is there on the live server...

Replied 30 Nov 2015 10:26:16
30 Nov 2015 10:26:16 Dave Smith replied:
Hi Simon,
Can you check that the connection file for the database contains the correct database credentials and that there is no issue with password complexity by changing the password on the remote server to something simple like 'test' (obviously change this after you confirm everything is good). Also check that your database user has the correct permissions. See if any of that helps...

I am not a DMX employee so they may have a better idea. Am just trying to offer some advice.

Replied 30 Nov 2015 11:06:29
30 Nov 2015 11:06:29 simon m replied:
Thanks Dave, appreciate your comments.

I can't even get to the stage where DW creates the connection file with the password in it. I open the Database Connection Dialog, enter my Data Source credentials etc, then the dmxdatabase.asp file is uploaded, then just before the connection file is created the 404 error comes back.

I even created an old basic Access DB with physical path, so it's nothing to do with mySQL permissions etc.

Maybe Teodor can help??
Replied 30 Nov 2015 11:18:03
30 Nov 2015 11:18:03 Dave Smith replied:
No worries Simon.

Don't forget that Live Support is available and online as we speak. Might allow you to get your issues resolved a little quicker by speaking with them.

Hope you get it resolved.
Replied 30 Nov 2015 17:18:30
30 Nov 2015 17:18:30 simon m replied:

The problem seems to be confined to a shared hosting environment, as this new site is a shared host.

I have created a test site and new database connection on a dedicated server running another website with no problems.

PS. Live support was also stumped.
Replied 30 Jan 2016 11:29:50
30 Jan 2016 11:29:50 Djibril SAKHO replied:
Hi all,
I have the same problem. I have just setup a new sample site and database, and I am getting this error.
- xamp
- PHP 7.0.1
I am just working on local server. Please help;
Replied 30 Jan 2016 11:53:05
30 Jan 2016 11:53:05 Dave Smith replied:
Please check you have a simple password for your database on XAMMP (as you are working locally there are no issues with security), something like password will do. You can also check the generated connection files that DMX creates.



Edit them to provide your new simplified password and just ascertain that they have all the correct details for your database connection.

Also make sure that the database user has the correct permissions (use PHPMyAdmin to do this by clicking on the Admin button inside the XAMMP control panel and clicking Users). If you are unsure add two users with the same name, one with the host set as % and the other as the host localhost (sometimes there can be issues with using the wildcard %), so to be sure add two users as I said.

Remember to either update your Database Connector with the new password/user or edit them manually.

Try all that and let us know how you get on.
Replied 30 Jan 2016 12:00:50
30 Jan 2016 12:00:50 Dave Smith replied:

When you deploy to a live environment (hosted) you can upload the connection files as normal and then edit them to add a new and complex password. Many hosts only allow passwords based on a complexity score of 100%. I usually find there is not an issue with complex passwords on hosted platforms but locally XAMMP does seem to have an issue with them.

Hope that makes sense DS.

Replied 30 Jan 2016 12:21:37
30 Jan 2016 12:21:37 Djibril SAKHO replied:
Thanks for your quick reply! Just to tell that I am new in PHP!
- I have only one file that DMX has created: dmxDatabase.php
- I have a very simple password: 123 (as I am in local and it is for training with DMX extensions, so...)

I do not see the database nor the server nor the password in the generated file. Where can I put these informations please.

Sorry for bad english, I am french speekin

Replied 30 Jan 2016 12:29:30
30 Jan 2016 12:29:30 Dave Smith replied:
It looks like the DMX Zone Database Connector has not generated the Connection files for your database connection. Please re-create your connection to your database using DMX Zone Database Connector.

This video may help if you have not seen it:

You should see a file alongside dmxDatabase.php with the same name you specified for your database connection.

Always happy to help DS so no problem. Teething issues can be a pain but once you are through them everything quickly becomes second nature.
Replied 30 Jan 2016 12:40:20
30 Jan 2016 12:40:20 Djibril SAKHO replied:
I have already see this video and I have repeat the process several time. This is the only one file I get each time.
I am DW CC 2015, frech version...
Replied 30 Jan 2016 12:55:55
30 Jan 2016 12:55:55 Dave Smith replied:
Silly question and I am not sure if it has any relevance on whether the Database Connector generates the files or not but does your database have any tables or is it just a database with a user?
Replied 30 Jan 2016 12:58:22
30 Jan 2016 12:58:22 Djibril SAKHO replied:
I create one table, but without records
Replied 30 Jan 2016 13:02:34
30 Jan 2016 13:02:34 Dave Smith replied:
Does the table have any fields? Remember the first field needs to be the Primary Key, set as INT and Auto Increment. Then maybe add a second field such as Name. Try inserting a test record through PHPMyAdmin and then try to re-create the DMX Zone Connection.

Sorry if you have already done this. I do not know your skill level with regards to MYSQL and am covering the basics.
Replied 30 Jan 2016 13:04:38
30 Jan 2016 13:04:38 Dave Smith replied:
I have to go out to pick up some horse feed but will be back later on. I will check the thread when I return DS. Go and have a coffee and get away from the computer for half an hour
Replied 30 Jan 2016 13:08:21
30 Jan 2016 13:08:21 Djibril SAKHO replied:
Noted Dave.
I have an ID field Primary Key, set as INT and Auto Increment and I have insert a recort. But I am still geting the error.
Replied 08 Feb 2016 17:18:36
08 Feb 2016 17:18:36 Djibril SAKHO replied:
It seems PHP 7 is the problem. Connection is working well with PHP 5.xx

Reply to this topic