DMXzone Extension Manager for Dreamweaver Support Product Page

Under investigation

extension manager. something went wrong, restart the extension manager

Reported 12 Feb 2017 05:06:24
have this problem
12 Feb 2017 05:06:24 Ahmed Saleh posted:
im getting this error every time i run the manger, if i hit cancel te manger start but never download any extension.


Replied 11 Mar 2017 16:22:45
11 Mar 2017 16:22:45 ahmed alotaibi replied:
I have same problem

The message "Something went the wrong restart the Extension Manager." : (Tow button: cancel | OK), chose OK then closing the Extension Manager, chose cancel don't close I can't download any extension.

MyPC is: Win 10 Pro 46-bit: Dreamweaver cc 2017
please help all user he has same Bugs.
Replied 11 Mar 2017 18:38:47
11 Mar 2017 18:38:47 George Petrov replied:
Could you please produce a log file as stated in this FAQ:

and then mail it to me for further investigation. mail to

George Petrov
Replied 13 Mar 2017 20:21:54
13 Mar 2017 20:21:54 ahmed alotaibi replied:
I've been sending e-mail. 2 days ago
Replied 14 Mar 2017 20:48:49
14 Mar 2017 20:48:49 George Petrov replied:
Hi Ahmed,

I've received you report - and see the problem. Seems it is related somehow in your localisation,
We are still investigating of possible solutions. Will keep you informed.

Replied 17 Mar 2017 16:24:39
17 Mar 2017 16:24:39 ahmed alotaibi replied:
I am still waiting to fix these problem
Replied 21 Apr 2017 15:16:04
21 Apr 2017 15:16:04 Luca lucag replied:
Please inform ALL and not just anyone who posted the problem.
Thank you.
Replied 21 Apr 2017 17:16:36
21 Apr 2017 17:16:36 George Petrov replied:
Hi Luca,

If you have the same problem - please generate and send me a report as described above.

Replied 18 May 2017 10:27:01
18 May 2017 10:27:01 MX Addict replied:
Same problem. Try to update to Server Connect 1.4.6 but get error:

something went wrong restart the extension manager
Replied 23 May 2017 07:02:53
23 May 2017 07:02:53 MX Addict replied:
When will this be fixed!!!!!!!!!!

Still problems with extension manager v1.2.1 can't update extensions. Everytime I need to restart extension manager but nothing happens.
Replied 25 May 2017 07:09:27
25 May 2017 07:09:27 Luca lucag replied:
I sent George my log file on 26/04/2017.
For now no answer. I'm waiting... waiting... waiting.
In the meantime, I stopped the auto start of DMXEM, and I was thinking of abandoning it completely and rushing to the old Adobe EM.
Replied 25 May 2017 07:43:25
25 May 2017 07:43:25 George Petrov replied:
Hi guys,

Yes we found the problem and are working on an update to be released next week.

For now you can just use the older version of the DEM

Sorry for the inconvenience - the problem was really difficult to fix, but we finally did. Need just a bit more testing.

Replied 25 May 2017 19:07:02
25 May 2017 19:07:02 MX Addict replied:
Hi George,

Thanks for the answer. DMXZone makes some great extensions but sometimes very disappointed in your service. I am waiting for several months with a mulltiple update records question. It has to do with insert date into mssql database. For some reason day and month keep reversing. See my topic below.

From DMXZone support they advice me to buy DMXZone data formatter and Calendar 3 for the solution. But still after months waiting it isn't working. It only works on Access database.
Replied 31 May 2017 06:46:43
31 May 2017 06:46:43 George Petrov replied:
Hi All,

We have the new update of DMXzone Extension Manager ready that should solve the above problems.
But before releasing it, we would like you to test it so you can check for your self if it all works.

Please download it from:

For Windows 64 bit:

For Mac:

If you still have problems, let me know directly

Replied 06 Jun 2017 11:15:38
06 Jun 2017 11:15:38 MX Addict replied:
Problem still there for Windows 64 bit. v1.2.2-rc1

Something went wrong restart the extension manager

C:\Users\myComp\AppData\Local\DMXzone Extension Manager\package.nw\node_modules\async\dist\async.js:837
        if (fn === null) throw new Error("Callback was already called.");

Error: Callback was already called.
    at C:\Users\myComp\AppData\Local\DMXzone Extension Manager\package.nw\node_modules\async\dist\async.js:837:32
    at C:\Users\myComp\AppData\Local\DMXzone Extension Manager\package.nw\node_modules\async\dist\async.js:356:16
    at iterateeCallback (C:\Users\myComp\AppData\Local\DMXzone Extension Manager\package.nw\node_modules\async\dist\async.js:865:24)
    at C:\Users\myComp\AppData\Local\DMXzone Extension Manager\package.nw\node_modules\async\dist\async.js:840:16
    at C:\Users\myComp\AppData\Local\DMXzone Extension Manager\package.nw\lib\extensions.js:7:515
    at C:\Users\myComp\AppData\Local\DMXzone Extension Manager\package.nw\lib\file.js:7:4526
    at C:\Users\myComp\AppData\Local\DMXzone Extension Manager\package.nw\lib\file.js:7:4526
    at FSReqWrap.oncomplete (fs.js:111:15)

Replied 06 Jun 2017 14:06:07
06 Jun 2017 14:06:07 George Petrov replied:

This is actually not the real error.

Could you send me the log you generated with
Mail it to

Replied 14 Jun 2017 15:38:34
14 Jun 2017 15:38:34 MX Addict replied:
Hi George,

Again problems extension manager Windows 64 bit. v1.2.2-rc1 after fresh big Windows 10 update version 15063.413

Need to restart and extensions won't update .
Replied 14 Jun 2017 16:15:23
14 Jun 2017 16:15:23 George Petrov replied:
Hi MX,

What error do you get exactly? Did you try to product a debug log? Maybe you can send it to me.
Also try to delete to local cache folder of DMXzone Extension Manager, located in :


Just delete it, restart DEM and try again.

Replied 15 Jun 2017 12:58:03
15 Jun 2017 12:58:03 George Petrov replied:
Hi MX,

I've updated the windows version so your problems should be fixed now.

Try this version:

Let me know if it works now.

Replied 26 Feb 2018 07:57:16
26 Feb 2018 07:57:16 fvafv asdfvafv replied:
In version 1.2.4 problem persists.
Windows 10 Pro 64 bit. Dreamveaver CC2018.
Replied 26 Feb 2018 08:06:29
26 Feb 2018 08:06:29 Teodor Kuduschiev replied:
Hello Rafal,
These issues have been fixed long time ago, almost an year ago.
Please explain what exactly your issue is, what is your OS and what version of EM are you trying to install/run?
Replied 26 Feb 2018 08:48:17
26 Feb 2018 08:48:17 fvafv asdfvafv replied:
I've got an error "Something went wrong. Restart EM. OK. Cancel". Restart doesn't fix the problem. I used older version 1.1.4 EM and it works fine.
I assume that the problem may be due to "ł" (slashed L) letter in my user profile (so in my user folder too). I've noticed that EM doesn't handle it correctly when installer trying to start EM with strange letter instead of "ł" and of course didn't find EM with incorrect path.

Reply to this topic